Wednesday, February 6, 2008

Exporting RCP application in Eclipse 3.4M4 with Java 1.6 on board

Recently I have been trying to export small RCP application from Eclipse 3.4M4. Unfortunately I encountered problems with exporting plug-ins which were using Java 1.6 specific features. I have even reported new bug, however Remi Chi Jian Suen was on his place and suggested me to add:
jre.compilation.profile = JavaSE-1.6
entry to the build.properties file of my plug-ins. It worked perfectly - thanks Remi! The only doubt I have is: shouldn't it be added automatically when user uses Java 1.6 no to let him go to similar troubles?


2 comments:

Markus said...

Instead of adding it automatically, a simple warning might be an alternative.

Chris Aniszczyk (zx) said...

Did you set a BREE to be J2SE 1.6?